Drag and drop to switch cell positions – virtual hold ({LButton down}) not work

Communication Forums Gazespeaker functionalities Drag and drop to switch cell positions – virtual hold ({LButton down}) not work

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Pierre Pierre 9 years, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #480
    Profile photo of Jeff Kang
    Jeff Kang

    Drag and drop to switch cell positions – simulated, virtual click-hold (Send {LButton down}) doesn’t work

    I don’t normally drag on the desktop. I remapped a button to simulate the holding-down/long-press of a left click.

    End::Send {LButton down}

    It’s more comfortable to avoid having to hold something down.

    Microsoft has the Sticky Keys accessibility option so that you don’t have to hold down a modifier. Too much holding down, like in mouse dragging, and swiping on a touchscreen can be bothersome for people who suffer from a repetitive strain injury, or other people with motor disabilities.

    A virtual click (Appskey::Click) releases the button. I think a “click” consists of a down press, and an up press. I can also physically press the left click, and I will also release a hold.

    I tried to pick up a cell by tapping my simulated “hold down” button (Send {LButton down}), and I was able to lift the cell, and move it around. However, when I want to move it over a cell to switch positions with it, and I press a left click (I tried both a physical left click, and a virtual left click), they won’t swap.

    If I pick up a cell by normally and physically holding down the left mouse button, and then I let go to a new location, cells will successfully move.

    I’m guessing that with the way I do it, when I want to let go of the hold, and I press the click, there is a down press before the release. Since that down press may not be anticipated, that down press is what messes things up. (Instead of down, and then up, it’s down, down, and then up).

    Would it be possible to allow this input method?


    • This topic was modified 9 years, 3 months ago by Profile photo of Jeff Kang Jeff Kang.
    Profile photo of Pierre

    Hi Jeff,
    I will try to find a solution.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.